PORT-SECURITY

PORT-SECURITY

Masih kembali ke tutorial saya, disini kita akan membahas mengenai sedikit konfigurasi Port Security pada Switch Cisco. Penjelasan sedikit mengenai Port Security

  • Port-security digunakan untuk mengamankan port switch melalui MAC Address, MAC Address yang dilarang menggunakan port switch maka akan di deny ketika mengirimkan packet melalui switch tersebut
  • Port-security dapat mencegah terjadinya MAC flooding atau spoofing attack
  • Ada 3 jenis Port-security violation mode
Security Violation Mode
Violation Mode Forwards Traffic Sends Syslog Message Displays Error Message Increases Violation Counter Shuts Down Port
Protect No No No No No
Restrict No Yes No Yes No
Shutdown No No No Yes Yes

Kita bisa mengatur agar port yang digunakan oleh suatu PC/Server, biasanya tidak bisa dipergunakan oleh PC lainnya. Sehingga apabila ada PC lain yang dikoneksikan ke port yang semestinya menjadi portnya PC Server, maka PC tersebut tidak akan bisa menggunakan port switch tersebut.

Pada PC Maling menggunakan IP 10.10.10.2/24 dan pada PC Server IPnya 10.10.10.1/24.

Selanjutnya kita konfigurasi Interface Fa0/1 dan Fa0/2 seperti dibawah.

Switch(config)#interface fa0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport port-security

Switch(config-if)#switchport port-security mac-address sticky

Switch(config-if)#switchport port-security violation shutdown

Switch(config-if)#ex

Switch(config)#interface fa0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport port-security

Switch(config-if)#swithport port-security mac-address sticky

Switch(config-if)#switchport port-security violation restrict

Pengetesannya, lakukanlah tes ping ke masing-masing PC dan pastikan mendapatkan reply, kemudian lepas kabel, dan tukarkan portnya, lalu test ping lagi.

Switch#show port-security address

Secure Mac Address Table

——————————————————————————-

Vlan Mac Address Type Ports Remaining Age

(mins)

—- ———– —- —– ————-

1 0030.F212.35E0 SecureSticky FastEthernet0/1 –

1 00D0.5875.25B5 SecureSticky FastEthernet0/2 –

——————————————————————————

Total Addresses in System (excluding one mac per port) : 0

Max Addresses limit in System (excluding one mac per port) : 1024

Switch#

Untuk pengujian, kita coba hubungkan PC penjahat ke switch, kemudian kita coba ping dari PC penjahat ke IP manapun, tujaunnya adalah agar ada trafic dari PC Maling. Sesaat setelah melakukan ping, maka akan ada peringatan yang menunjukkan bahwa interface pada Switch berubah menjadi shutdown.

Switch#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

Perhatikan bahwa saat ini status dari interface fa0/1 adalah shutdown.
Untuk mengaktifkannya kembali, kita harus shutdown kemudian no shutdown secara manual.

Switch(config)#interface fa0/1

Switch(config-if)#shutdown

Switch(config-if)#no shutdown

Ada 3 violation yang bisa dipilih ketika suatu port pada switch digunakan oleh PC yang tidak semestinya yaitu sebagai berikut :

  • Protect : data yang dikirim melalui port tersebut akan dibiarkan tidakdikirim
  • Restrict : seperti protect namun dengan mengirimkan notifikasi denganSNMP
  • Shutdown : portnya akan di shutdown secara otomatis, untuk mengembalikannya, shutdown portnya secara manual kemudian no shutdown.

Leave a Reply

Your email address will not be published. Required fields are marked *